发布网友 发布时间:2022-04-22 00:37
共2个回答
热心网友 时间:2022-04-12 19:47
编一个典型配置的案例, 你看看吧, 只列出关键的命令
=========
一,交换机配置
switch#vlan database
switch(vlan)#vlan 2 name vlan2
switch(vlan)#vlan 3 name vlan3 //定义vlan
switch(vlan)#exit
switch(config)#interface f0/1
switch(config-if)#switch mode access
switch(config-if)#switch access vlan2
switch(config-if)#exit
switch(config)#interface f0/2
switch(config-if)#switch mode access
switch(config-if)#switch access vlan3 //将端口加入vlan
switch(config-if)#exit
switch(config)#interface f0/24
switch(config-if)#switch mode trunk
switch(config-if)#encapsulation dot1q //打开干道并封装为dot1q
switch(config-if)#exit
二,路由器配置
router(config)#interface f0/0
router(config-if)#no ip address //主接口下不配ip地址
router(config-if)#no shutdown
router(config)#interface f0/0.1
router(config-if)#encapsulation dot1q 2
router(config-if)#ip address 192.168.1.1 255.255.255.0 //子接口封装为dot1q并与vlan关联
router(config-if)#no shutdown
router(config)#interface f0/0.2
router(config-if)#encapsulation dot1q 3
router(config-if)#ip address 192.168.2.1 255.255.255.0
router(config-if)#no shutdown
此时单臂路由配置完毕!
router(config)#service dhcp //开启dhcp server 功能
router(dhcp-config)#ip dhcp pool test1 //定义作用域
router(dhcp-config)#network 192.168.1.0 255.255.255.0 //要分配的网络
router(dhcp-config)#default-router 192.168.1.1 //vlan的网关
router(dhcp-config)#dns-server 202.102.192.68 //dns server ip 地址
router(config)#ip dhcp pool test2
router(dhcp-config)#network 192.168.2.0 255.255.255.0
router(dhcp-config)#default-router 192.168.2.1
router(dhcp-config)#dns-server 202.102.192.68
此时dhcp server 配置完毕!
router(config)#access 1 deny 192.168.1.3 0 //假设pc的地址为1.3.
router(config)#access 1 permit 192.168.1.0 0.0.0.255
router(config)#access 1 permit 192.168.2.0 0.0.0.255 //允许内网访问internet
router(config)#ip nat pool xyz 202.202.202.202 202.202.202.202 netmask 255.255.255.0 //定义nat地址池
router(config)#ip nat inside source list 1 pool xyz overload //定义内网与*的关联
router(config)#interface f0/0.1
router(config-if)#ip nat inside
router(config)#interface f0/0.2
router(config-if)#ip nat inside //定义此接口为进站
router(config)#interface f0/1
router(config-ip)#ip address 202.202.202.202 255.255.255.0
router(config-if)#no shutdown
router(config-if)#ip nat outside //定义些接口为出站
到此时实验配置好了.
方法很简单. 在路由器与交换机互联的端口上. 封装子接口, 配置相关命令. 再在交换机与之相连的端口上,配置trunk. 不能上网的, 禁止 nat就可以了.
热心网友 时间:2022-04-12 21:05
单臂路由的典型啊,设置个TRUCK口连接交换机和路由器,就可以互访了.至于PC3不能上*,在路由里设访问控制就是了,禁止PC3的任何数据通过广域口